ג'ון פוסטל

ג'ון פוסטל: האיש שניהל את האינטרנט לבדו

בינואר 1998 שלח ג'ון פוסטל (Jon Postel) דואר אלקטרוני לשמונה מתוך שנים-עשר הארגונים המפעילים את שרתי השורש של האינטרנט, וביקש מהם בשקט להפנות את השרתים שלהם מהרשות הממשלתית המוסמכת אל שרת שבשליטתו האישית. הם עשו זאת – כיוון שבמשך כמעט שלושים שנה, כאשר ג'ון פוסטל ביקש מתשתית האינטרנט לבצע משהו, היא עשתה זאת. בתוך ימים, יועץ מדעי לנשיא איים עליו אישית: "לעולם לא תעבוד עוד באינטרנט". זה היה ככל הנראה הרגע האחרון בהיסטוריה שבו אדם בודד יכול היה להפנות את הצנרת המרכזית של האינטרנט באמצעות דוא"ל ולקבל ציות ללא הצבעה רשמית – וזה ממחיש, בקטן, בדיוק כמה אמון אישי ובלתי פורמלי הניע את הרשת לאורך כל תחילת דרכה.

סטודנט בינוני בין עתידיים אגדיים

ג'ונתן ברוס פוסטל (Jonathan Bruce Postel) נולד ב-6 באוגוסט 1943 באלטדנה שבקליפורניה. הוא למד בתיכון ואן נייס (Van Nuys High School) לצד סטיב קרוקר (Steve Crocker) ווינט סרף (Vint Cerf), שני חברים לספסל הלימודים שהפכו לאדריכלים שותפים של האינטרנט המוקדם – אם כי לפי הגיליון האקדמי שלו, פוסטל היה הסטודנט הפחות בולט מבין השלושה. הוא המשיך לאוניברסיטת קליפורניה בלוס אנג'לס (UCLA), שם קיבל תואר ראשון בהנדסה ב-1966, תואר שני ב-1968, ותואר דוקטור במדעי המחשב ב-1974 תחת הנחייתו של דייב פארבר (Dave Farber). בדצמבר 1969, לפני שסיים את הדוקטורט, החל פוסטל לעבוד ב-UCLA כמהנדס מחקר לתארים מתקדמים ב-ARPANET, רשת משרד ההגנה שתהפוך לאב הקדמון הישיר של האינטרנט, ושיתף פעולה עם סרף וקרוקר על פרוטוקולי הרשת הראשונים, תוך דחיפה ליצירת פרוטוקולים נוספים שיטפלו בתקשורת בין רשתות נפרדות – הזרע הרעיוני למה שהפך לחבילת פרוטוקולי האינטרנט.

עריכת הכללים שכולם עקבו אחריהם

תפקידו המוסדי המתמשך ביותר של פוסטל החל כמעט מיד ולא הסתיים באמת: מ-1969 ועד מותו, הוא שימש כעורך סדרת ה-Request for Comments (בקשות לתגובות), המסמכים שדרכם מוצעים, נדונים ומאומצים רשמית התקנים הטכניים של האינטרנט. הוא חיבר או היה שותף לחיבור של יותר מעשרים מהם, כולל RFC 791, 792, ו-793 – המפרטים הבסיסיים עבור פרוטוקול האינטרנט (IP) ופרוטוקול בקרת התמסורת (TCP) שעדיין מהווים את הבסיס לכל תעבורת האינטרנט – וכן ה-RFCs שקבעו את הארכיטקטורה של מערכת שמות הדומיין (DNS). מראשית ימי מספור הרשתות, פוסטל גם ניהל את רשות הקצאת המספרים באינטרנט (IANA), כאשר בתחילה ביצע את כל המשימה של הקצאת כתובות רשת ופרמטרים של פרוטוקולים ביד, וניהל את הדומיין הלאומי .us בעודו מכהן במועצת ארכיטקטורת האינטרנט (IAB) ובחבר הנאמנים של איגוד האינטרנט. עבודתו היומיומית לאורך תקופה זו הייתה ניהול חטיבת רשתות המחשבים במכון למדעי המידע של אוניברסיטת דרום קליפורניה (USC), תפקיד שלקח על עצמו במרץ 1977.

עקרון החוסן

תרומתו המצוטטת ביותר של פוסטל למדעי המחשב אינה מוסד אלא משפט – עקרון תכנוני שנוסח לראשונה ב-RFC 760 ומאוחר יותר ב-RFC 1122: "יישום צריך להיות שמרני בהתנהגות השליחה שלו, וליברלי בהתנהגות הקבלה שלו", שמסוכם בדרך כלל כ"היה ליברלי במה שאתה מקבל, ושמרני במה שאתה שולח". העקרון, שנודע מאז כ"חוק פוסטל", עיצב במשך עשורים את הדרך שבה נכתבה תוכנת רשת, ועודד מערכות לסבול קלט פגום או לא צפוי מאחרות בעודן מקפידות על סטנדרטים מחמירים במה שהן משדרות – פילוסופיה הנדסית שהאריכה ימים יותר מרוב הפרוטוקולים הספציפיים שעבורם נכתבה.

THE FREE TEST
How high is yours?

Twenty questions, eight minutes on the clock, and a percentile measured against everyone who has taken it. No sign-up.

Take the IQ test →

ניסוי שרתי השורש של 1998

המחלוקת המגדירה בקריירה של פוסטל הגיעה לקראת סופה. ב-28 בינואר 1998, כאשר ממשלת ארה"ב וחברת Network Solutions Inc היו נעולות בסכסוך לא פתור על עתידו המסחרי של ה-DNS, פוסטל שלח דוא"ל לשמונה מתוך שנים-עשר מפעילי שרתי השורש של האינטרנט והורה להם להפנות את שרתיהם מהשורש הסמכותי של Network Solutions בכתובת A.ROOT-SERVERS.NET למכונה בשליטת IANA, בכתובת DNSROOT.IANA.ORG. המפעילים, שרבים מהם הכירו את פוסטל וסמכו עליו אישית במשך עשורים, צייתו ללא תקריות, ותעבורת האינטרנט הרגילה נמשכה ללא הפרעה. אך ההשלכות הפוליטיות היו מיידיות וחמורות: איירה מגזינר (Ira Magaziner), יועץ מדיניות האינטרנט של ממשל קלינטון, הזהיר את פוסטל אישית ש"לעולם לא יעבוד עוד באינטרנט" והורה לבטל את הניסוי. בתוך שבוע הוציא המינהל הלאומי לטלקומוניקציה ומידע הצעות שהרחיבו בסופו של דבר, ולא צמצמו, את הפיקוח הממשלתי האמריקאי הרשמי על ניהול ה-DNS – ככל הנראה ההפך ממה שפעולתו של פוסטל נועדה להוכיח כמיותר.

מוות ומחווה של הערצה

פוסטל מת ב-16 באוקטובר 1998, בגיל 55, מסיבוכים בעקבות ניתוח החלפת מסתם לב בסנטה מוניקה – חודשים ספורים בלבד לאחר עימות שרתי השורש ומעט לפני הקמת ICANN, הארגון שיהפוך למוסד רשמי את הסמכות שפוסטל הפעיל באופן לא פורמלי במשך עשורים. דברי ההספד שבאו לאחר מכן היו אישיים בצורה יוצאת דופן לתחום טכני: וינט סרף כתב את RFC 2468, "אני זוכר את IANA", המנציח את פוסטל ישירות בתוך הספרות הטכנית המרכזית של האינטרנט, כבוד ללא תקדים של ממש. איגוד האינטרנט יצר את פרס השירות על שם ג'ונתן ב. פוסטל ב-1999, כשהוא מכריז על פוסטל עצמו כזוכה הראשון לאחר מותו; הוא הוכנס להיכל התהילה של האינטרנט כחלוץ בשנת 2012; והמכון למדעי המידע של USC קרא על שמו את מרכז פוסטל. כשעיתונאי כינה אותו פעם "אלוהי האינטרנט", פוסטל הדף את התווית בענווה אופיינית: "כמובן שאין 'אלוהי אינטרנט'. האינטרנט עובד כי הרבה אנשים משתפים פעולה כדי לעשות דברים יחד". ה-Economist היה פחות מוכן לוותר לו, וכתב שאם ל-Net אכן יש אלוהים, הוא כנראה ג'ון פוסטל.

מדוע ג'ון מכונה גאון

הגאונות המיוחסת לפוסטל יוצאת דופן בקרב הדמויות שזוכות לתואר: זו אינה המצאה או מוצר בודד, אלא שלושה עשורים של ניהול שקט, ללא תשלום ברובו, שהחזיק יחד מערכת טכנית מורכבת מדי וצומחת מהר מדי מכדי שבירוקרטיה רשמית כלשהי של התקופה תוכל לנהל אותה באותה יעילות של אדם אחד מהימן. המחווה של סרף ב-RFC 2468 והניסוח של ה-Economist על "אלוהי האינטרנט" מצביעים שניהם על אותה טענה בסיסית – שהלכידות המוקדמת של האינטרנט הייתה תלויה פחות במסמך פרוטוקול זה או אחר ויותר בשיקול הדעת האישי של פוסטל, הגינותו, ונכונותו לבוררות בסכסוכים טכניים שלא הייתה להם סמכות פורמלית ברורה ליישובם. חוק פוסטל עצמו מצוטט באופן קבוע בתוכניות לימוד להנדסת תוכנה כתובנה מקורית ועמידה באמת על תכנון מערכות.

הסיבוך הכן הוא שמודל ניהול זה – אדם אחד, כמעט בלתי אחראי, שמקבל החלטות משמעותיות לגבי תשתיות גלובליות באמצעות דוא"ל אישי – היה גם בדיוק מה שאירוע שרתי השורש ב-1998 חשף כשביר ו, בעיני ממשלת ארה"ב, כמדאיג. סמכותו של פוסטל עבדה כי אנשים סמכו עליו באופן אישי; זו מעולם לא הייתה מבנה אחראי דמוקרטית, והחלפתו על ידי ICANN לאחר מותו הובנה באופן נרחב כמיסוד הכרחי של כוח שלא יכול היה, באינטרנט שהופך יותר ויותר מסחרי ונתון למחלוקת פוליטית, להמשיך להישען על שיקול דעתו של מהנדס בודד.

מורשת

פוסטל מת לפני שהאינטרנט שהוא עזר לנהל הפך לפלטפורמה צרכנית ומסחרית המונית כפי שהוא היום, אך הפרוטוקולים שהוא כתב או ערך – TCP/IP ומערכת שמות הדומיין (DNS) בראשם – נותרו המצע המילולי של האינטרנט המודרני, והמבנים המוסדיים שנוצרו בעקבותיו, מהמשך פעילות IANA ועד ICANN עצמה, עדיין נושאים את צורתה של המערכת הלא-פורמלית מבוססת האמון שהוא בנה כמעט לבדו.